Wordpress RSS to Tumblr

TumblingJazz Tumblr bot discussion
tahoe012
Posts: 102
Joined: Mon Jan 06, 2020 10:56 am

Wordpress RSS to Tumblr

Post by tahoe012 » Sat Apr 03, 2021 1:38 am

Can I insert a timer so lets say there are 100 Tumblrs. The RSS posting from WP Blog1 (each new blog post) would post to all 100 tumblrs but at different intervals so all 100 don't get slammed at the same time with the same WP Blog Post?

tahoe012
Posts: 102
Joined: Mon Jan 06, 2020 10:56 am

Re: Wordpress RSS to Tumblr

Post by tahoe012 » Sat Apr 03, 2021 10:33 am

Martin, Also, posts coming from the RSS feed to Tumblr are getting odd characters as can be seen on this Tumblr: https://anakinsbugs.tumblr.com - Realizing there is not a software problem but perhaps this relates to the Meta information that the documentation mentions requires knowledge of Xpath, XML and etc... it might be over my head to make this function properly in which case I will understand. Hopefully, it's an easy fix for me.

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Wordpress RSS to Tumblr

Post by martin@rootjazz » Sun Apr 04, 2021 6:18 pm

tahoe012 wrote:
Sat Apr 03, 2021 1:38 am
Can I insert a timer so lets say there are 100 Tumblrs. The RSS posting from WP Blog1 (each new blog post) would post to all 100 tumblrs but at different intervals so all 100 don't get slammed at the same time with the same WP Blog Post?
So you want to setup 100 actions, each with a different account, each posting the same RSS feed.

But you want to modify how / when they run?


I Guess the only way to do this, if this is what you want, is to add all with the processor PAUSED.
Then select all these new actions and right click > RANDOMISE OVER HOURS

IF you enter 168 (7 days) then the 100 blogs will divide themselves over the next days, each blog posting about 2 hours after the last. Or if you enter 500, there will be a 5 hour gap between each blog posting the same article

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Wordpress RSS to Tumblr

Post by martin@rootjazz » Sun Apr 04, 2021 6:20 pm

tahoe012 wrote:
Sat Apr 03, 2021 10:33 am
Martin, Also, posts coming from the RSS feed to Tumblr are getting odd characters as can be seen on this Tumblr: https://anakinsbugs.tumblr.com - Realizing there is not a software problem but perhaps this relates to the Meta information that the documentation mentions requires knowledge of Xpath, XML and etc... it might be over my head to make this function properly in which case I will understand. Hopefully, it's an easy fix for me.
Can you let me know the RSS feed you are using
And how you set the action up to post from this feed.

Email me if this is private info:

Code: Select all

support[at]rootjazz[dot]com
It looks like an encoding issue, but I'd need to see what is happening exactly to understand / fix/

Also submit logs, might be useful as well

HELP > LOGS > SUBMIT

then send your logs ID - the numbers are sufficient (displayed after successful uploading of logs)




Regards,
Martin

tahoe012
Posts: 102
Joined: Mon Jan 06, 2020 10:56 am

Re: Wordpress RSS to Tumblr

Post by tahoe012 » Sun Apr 04, 2021 11:39 pm

Hi Martin,

Thanks for looking into this.

17478 is the log file number.

The feed is: walrusvideo.com/feed

I run this feed with IFTTT sending to a different Tumblr and not getting any unwanted characters.

Here is example:

IFTTT: walrusvideo.com/feed
https://aseasyasdeanspie.tumblr.com/

tumblingJazz: walrusvideo.com/feed
https://anakinsbugs.tumblr.com/

tahoe012
Posts: 102
Joined: Mon Jan 06, 2020 10:56 am

Re: Wordpress RSS to Tumblr

Post by tahoe012 » Sun Apr 04, 2021 11:41 pm

At this point it looks like the apostrophe is the character that is affected.

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Wordpress RSS to Tumblr

Post by martin@rootjazz » Mon Apr 05, 2021 2:31 pm

This is what appears when I look at the website:

Image

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Wordpress RSS to Tumblr

Post by martin@rootjazz » Mon Apr 05, 2021 2:34 pm

Ok, so it seems the encoding is unicode (for some reason).

Code: Select all

<?xml version="1.0" encoding="UTF-8"
and the src says UTF-8 which is the standard encoding used for all websites which are handled correctly. Err not really sure what is going on and why it appears like that as the program handles UTF-8 by default.

So either the page is wrong in it's encoding, or I don't undersand something with the page encoding spec.

Will take a look

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Wordpress RSS to Tumblr

Post by martin@rootjazz » Mon Apr 05, 2021 3:58 pm

OK there is a web server mis-configuration. The web server is telling the response it is: ISO-8859-1 which is incorrect, which is why it shows wrong in the browser as well. The response is not being decoded with UTF-8 encoding which it needs to be.

errr, this is awkward as not sure how can handle this situation. As the program currently *IS* doing it correctly, from the HTTP response, the server is saying show those encoded characters. IFTTT is actually doing it WRONG by not showing them, they must be forcing UTF-8 for all responses, which is technically wrong as they are ignoring the response character set.

Problem with forcing it to UTF8 would be it might break for other configs that do require the ISO-8859-1.

There is no concept in the code for forcing it for a single site...


But I'll take a look and see what I Can hack in for you and get back to you


Regards,
Martin

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Wordpress RSS to Tumblr

Post by martin@rootjazz » Mon Apr 05, 2021 6:01 pm

goto your CONFIG directory:
%appdata%\rootjazz\tumbling jazz\config


Add the file:
force_utf8.txt


and from next update it should work correctly

Post Reply