ERROR: You must set the credentials to use the Twitter API

Support / help / discussion forum for twitter bot
Post Reply
ben1989
Posts: 1
Joined: Sat Feb 17, 2018 7:53 pm

ERROR: You must set the credentials to use the Twitter API

Post by ben1989 » Sat Feb 17, 2018 7:57 pm

Got a issue

Reply to tweet does not work.

Getting this error:

Code: Select all

20:51:37: *** Pre Search Setup***
20:51:37: Checking account: <username-removed>
20:51:38: Initial search setup: <username-removed>
20:51:38: Loading previous db logs: 2c72fa68-a7fc-4f5e-b109-cdec3f70c12d_ReplyTweet
20:51:38: Loaded previous db logs: 1 processed: 1 within 24hrs: 1
20:51:38: *** Performing Search ***
20:51:38: custom search builder
20:51:38: Loading previous db logs: 2c72fa68-a7fc-4f5e-b109-cdec3f70c12d_ReplyTweet
20:51:38: Loaded previous db logs: 1 processed: 1 within 24hrs: 1
20:51:38: Max Results Wanted: 50
20:51:38: Setup custom search controller
20:51:38: One search stage detected, setting default per item per stage value to max: 50
20:51:38: Custom search run: search: <searchterm-removed>
20:51:38: Perform custom search: #chain/total: 1/1 using: <username-removed>
20:51:38: Start search: LatestTweetOf with: <searchterm-removed> using: <username-removed>
20:51:38: * ERROR: You must set the credentials to use the Twitter API. (Read the exception description field for more information)
20:51:38: Found: 0
20:51:38: 
*********
Processed: 0/50
Failed: 0
*********

20:51:38: Started: 17/02/2018 20:51 PM
Finished: 17/02/2018 20:51 PM
Why?

What does "Read the exception description field for more information" mean or where can I find this?

The credentials are correct, it worked only once than it stopped working.

support@rootjazz
Posts: 2319
Joined: Tue Feb 02, 2016 1:58 pm

Re: ERROR: You must set the credentials to use the Twitter API

Post by support@rootjazz » Mon Feb 19, 2018 2:09 pm

ben1989 wrote:
Sat Feb 17, 2018 7:57 pm
Got a issue

Reply to tweet does not work.

Getting this error:

Code: Select all

20:51:37: *** Pre Search Setup***
20:51:37: Checking account: <username-removed>
20:51:38: Initial search setup: <username-removed>
20:51:38: Loading previous db logs: 2c72fa68-a7fc-4f5e-b109-cdec3f70c12d_ReplyTweet
20:51:38: Loaded previous db logs: 1 processed: 1 within 24hrs: 1
20:51:38: *** Performing Search ***
20:51:38: custom search builder
20:51:38: Loading previous db logs: 2c72fa68-a7fc-4f5e-b109-cdec3f70c12d_ReplyTweet
20:51:38: Loaded previous db logs: 1 processed: 1 within 24hrs: 1
20:51:38: Max Results Wanted: 50
20:51:38: Setup custom search controller
20:51:38: One search stage detected, setting default per item per stage value to max: 50
20:51:38: Custom search run: search: <searchterm-removed>
20:51:38: Perform custom search: #chain/total: 1/1 using: <username-removed>
20:51:38: Start search: LatestTweetOf with: <searchterm-removed> using: <username-removed>
20:51:38: * ERROR: You must set the credentials to use the Twitter API. (Read the exception description field for more information)
20:51:38: Found: 0
20:51:38: 
*********
Processed: 0/50
Failed: 0
*********

20:51:38: Started: 17/02/2018 20:51 PM
Finished: 17/02/2018 20:51 PM
Why?

What does "Read the exception description field for more information" mean or where can I find this?

The credentials are correct, it worked only once than it stopped working.
There must be an issue with twitter app credential you provided.

Did you give all the permission to your app?
When did you create the app? Are you running too aggresive action via the app?

I think the APP is not well configured. But, i can't say this confidently as i am not twitter api expert and i am forwarding this to admin for troubleshooting.

But, please read these also, if you can solve your issue yourself. :)

viewtopic.php?f=30&t=1544
viewtopic.php?f=30&t=1474
viewtopic.php?f=30&t=1635
viewtopic.php?f=30&t=1646

Post Reply