Application doesn't start!

Support / help / discussion forum for twitter bot
User avatar
martin@rootjazz
Site Admin
Posts: 17751
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Application doesn't start!

Post by martin@rootjazz » Thu Jun 25, 2015 8:31 pm

Please note:

Twitterdub requires the Microsoft .Net 4.5 FULL framework to be installed. If you are unsure if you have it installed you can check with this little utility tool:
https://www.raymond.cc/blog/wp-content/ ... hp?id=1741



Or to just download the framework from Microsoft.com go here:
https://www.microsoft.com/en-us/downloa ... x?id=30653

bitcoin
Posts: 910
Joined: Tue Jul 04, 2017 1:25 am

Re: Application doesn't start!

Post by bitcoin » Fri Jul 21, 2017 9:25 pm

I just updated to:
1.313 - 21/07/2017

twitter.exe process appears, gets suspended for a short while and then kills itself...

Where to start? :)

Post-edit: 404: https://raymondcc.r.worldssl.net/NET_Detector.exe
This one works: http://www.majorgeeks.com/files/details ... ector.html
Image

Bri
Posts: 209
Joined: Fri Nov 13, 2015 10:53 am

Re: Application doesn't start!

Post by Bri » Sat Jul 22, 2017 7:39 pm

it might be your anti-virus, add the twitter dub location to the whitelist

bitcoin
Posts: 910
Joined: Tue Jul 04, 2017 1:25 am

Re: Application doesn't start!

Post by bitcoin » Sat Jul 22, 2017 7:57 pm

While I would be very sad if it was the AV, I can report it is not the AV (or other security related tools).

I also installed twitterdub_installer_v1.312.exe and TD starts. I installed twitterdub_installer_v1.313.exe and above described problem re-appears.
Last edited by bitcoin on Mon Jul 24, 2017 2:38 pm, edited 1 time in total.

bitcoin
Posts: 910
Joined: Tue Jul 04, 2017 1:25 am

Re: Application doesn't start!

Post by bitcoin » Sat Jul 22, 2017 8:08 pm

Code: Select all

Application: Twitter.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentException
   at System.Reflection.RuntimeAssembly.GetResource(System.Reflection.RuntimeAssembly, System.String, UInt64 ByRef, System.Runtime.CompilerServices.StackCrawlMarkHandle, Boolean)
   at System.Reflection.RuntimeAssembly.GetManifestResourceStream(System.String, System.Threading.StackCrawlMark ByRef, Boolean)
   at System.Reflection.RuntimeAssembly.GetManifestResourceStream(System.String)
   at <Module>..cctor()

Exception Info: System.TypeInitializationException
   at LibTwitter.Config.init()
   at LibUtil.ConfigConstants.য흹Ӣ匓㩻�攎끆(System.String)
   at DynamicClass.(System.Object, System.String)
   at ꒚꿢菟ᄍ.껞Ҵ逪姣爚譫ꡍẼ(System.Object, System.String)
   at 嘐樨켔ঃ욦쿀�묇.岌愁푶쪔ழ�響萬(System.String[])


bitcoin
Posts: 910
Joined: Tue Jul 04, 2017 1:25 am

Re: Application doesn't start!

Post by bitcoin » Sat Jul 22, 2017 8:08 pm

Code: Select all

Faulting application name: Twitter.exe, version: 1.3.1.3, time stamp: 0x5972575a
Faulting module name: KERNELBASE.dll, version: 10.0.14393.1378, time stamp: 0x594a13be
Exception code: 0xe0434352
Fault offset: 0x000da9f2
Faulting process id: 0x4d6c
Faulting application start time: 0x01d3032492aac75f
Faulting application path: C:\Program Files (x86)\Twitterdub\Twitter.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 1728015a-a273-4d85-a841-fd39978d8050
Faulting package full name: 
Faulting package-relative application ID: 

bitcoin
Posts: 910
Joined: Tue Jul 04, 2017 1:25 am

Re: Application doesn't start!

Post by bitcoin » Sat Jul 22, 2017 9:29 pm

FROM: https://stackoverflow.com/questions/147 ... ler-but-it
Your assumption that it is not crashing is not correct. 0xe0434352 is a low-level CLR exception code. Get ahead by writing an event handler for <snip>
FROM: https://stackoverflow.com/questions/232 ... 000000a49d
Sounds like you just missed some exception handling in your application when doing file IO. That would be the first place to start.
Some useless MSDN blah?

I tried to find out how to do a trace log or something, but you may assist me there if it's even required...

User avatar
martin@rootjazz
Site Admin
Posts: 17751
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Application doesn't start!

Post by martin@rootjazz » Mon Jul 24, 2017 8:36 pm

I'll rebuild it, sounds like the installer didn't build correctly and I didn't notice

User avatar
martin@rootjazz
Site Admin
Posts: 17751
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Application doesn't start!

Post by martin@rootjazz » Mon Jul 24, 2017 8:40 pm

https://rootjazz.com/twitterdub/updatetesting.html



tested and working here


in future for urgent things, feel free to send in an email

Code: Select all

support[at]rootjazz[dot]com

bitcoin
Posts: 910
Joined: Tue Jul 04, 2017 1:25 am

Re: Application doesn't start!

Post by bitcoin » Mon Jul 24, 2017 11:16 pm

Yeah the program started! I thought even you deserved a weekend with not too much stress... I spent it hunting down RSS feeds and trippled my twitter reach within an hour. Hasn't gone down since. So win-win? :)

And did you get the answer of the problem by looking at the logs? Or something different altogether? Curious, for I can hardly get any usable info from it...

Thanks!!

Post Reply