JSON 401 bug still exists? [BUG]

Support / help / discussion forum for twitter bot
Post Reply
darude
Posts: 61
Joined: Fri Mar 11, 2022 3:39 am

JSON 401 bug still exists? [BUG]

Post by darude »

When I try to "verify web login" or do "like" action with twitterdub, it doesnt work

and the response is:

Code: Select all

Failed JSON response: 401
https://twitter.com/i/api/2/timeline/home.json?include_profile_interstitial_type=1&include_blocking=1&include_blocked_by=1&include_followed_by=1&include_want_retweets=1&include_mute_edge=1&include_can_dm=1&skip_status=1&cards_platform=Web-12&include_cards=1&include_ext_alt_text=true&include_reply_count=1&tweet_mode=extended&include_entities=true&include_user_entities=true&include_ext_media_color=true&send_error_codes=true&earned=1&count=100&ext=mediaStats%2ChighlightedLabel
{"errors":[{"message":"Could not authenticate you","code":32}]}
ERROR RESP FROM TWITTER: 32 Could not authenticate you
* TESTING for known failure text: Could not authenticate you
is this the login bug, where the application thinks the account is still logged in while it isnt or something with my setup / proxy?

the account works perfectly normal when using "open acc in browser session" with the proxy, so I would assume it is not the account.

I submitted the logs ID: 50486
iamshivi
Posts: 16
Joined: Fri Oct 01, 2021 7:36 am

Re: JSON 401 bug still exists? [BUG]

Post by iamshivi »

getting a similar 404 json error while DMing
User avatar
martin@rootjazz
Site Admin
Posts: 30955
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: JSON 401 bug still exists? [BUG]

Post by martin@rootjazz »

iamshivi wrote: Wed Oct 05, 2022 11:00 pm getting a similar 404 json error while DMing
More info please. 404 means a URL provided does not exist. Double check your input is correct

Then if it looks correct to you. Please, read through this post and submit your issue accordingly. Not everything will be relevant to your issue, but have a read as it gives an idea of the information you can provide to help me help you as quickly as possible without delays in having to request additional information :)

https://rootjazz.com/forum/viewtopic.php?f=23&t=1634



Regards,
Martin
User avatar
martin@rootjazz
Site Admin
Posts: 30955
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: JSON 401 bug still exists? [BUG]

Post by martin@rootjazz »

darude wrote: Wed Oct 05, 2022 12:42 am When I try to "verify web login" or do "like" action with twitterdub, it doesnt work

and the response is:

Code: Select all

Failed JSON response: 401
https://twitter.com/i/api/2/timeline/home.json?include_profile_interstitial_type=1&include_blocking=1&include_blocked_by=1&include_followed_by=1&include_want_retweets=1&include_mute_edge=1&include_can_dm=1&skip_status=1&cards_platform=Web-12&include_cards=1&include_ext_alt_text=true&include_reply_count=1&tweet_mode=extended&include_entities=true&include_user_entities=true&include_ext_media_color=true&send_error_codes=true&earned=1&count=100&ext=mediaStats%2ChighlightedLabel
{"errors":[{"message":"Could not authenticate you","code":32}]}
ERROR RESP FROM TWITTER: 32 Could not authenticate you
* TESTING for known failure text: Could not authenticate you
is this the login bug, where the application thinks the account is still logged in while it isnt or something with my setup / proxy?

the account works perfectly normal when using "open acc in browser session" with the proxy, so I would assume it is not the account.

I submitted the logs ID: 50486

Ok, try a CLEAN LOGIN:

Goto the ACCOUNTS tab
Check the account
Right click the account and select DELETE COOKIES
Uncheck option to USE EXISTING COOKIES (if option exists)
Check Force (if option exists)
click the link VERIFY:LOGIN

This will create an action and send it to the PROCESSING TAB
Goto the processing tab and click RUN. The action will run.
You can double click the action to view the logs and submit logs.

If that doesn't resolve your issue, please submit logs:

HELP > LOGS > SUBMIT

then send your logs ID - the first 4 numbers is sufficient (displayed after successful uploading of logs)


If that still fails. Try on a different IP to see if it's IP based.


IF issue persist. If I could test the account(s), that would be very helpful in trying to find out what is going on and fix / update as requried: If that is ok with you, please export the account(s) (export button bottom right of accounts list) and email the exported file(s):

Code: Select all

support[at]rootjazz[dot]com

Regards,
Martin






Regards,
Martin
Post Reply