WebBrowser not working

Post Reply
Cheerboatfun
Posts: 122
Joined: Wed Nov 22, 2017 2:38 pm

WebBrowser not working

Post by Cheerboatfun » Wed Mar 17, 2021 7:26 pm

hi martin,

when I launch an action and want to run it with WebBrowser, the execution window opens but fails and throws an error in the application saying: "an error has occurred. Submit logs and send to support". I also tried to login via WebBrowser on the Accounts>Open Acc in browser

logs sent: ***1559

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: WebBrowser not working

Post by martin@rootjazz » Thu Mar 18, 2021 9:00 pm

session not created: This version of ChromeDriver only supports Chrome version 88
Current browser version is 86.0.4240.75 with binary path C:\Program Files (x86)\Google\Chrome\Application\chrome.exe (SessionNotCreated)
Update chrome, or install the old version of chromedriver


--------------------------------
Due to chrome updates you will need the specific CHROME DRIVER for your CHROME install.

Info on how to do that here:

viewtopic.php?f=28&t=8193&p=50920&hilit ... ver#p50920



Regards,
Martin

Cheerboatfun
Posts: 122
Joined: Wed Nov 22, 2017 2:38 pm

Re: WebBrowser not working

Post by Cheerboatfun » Fri Mar 19, 2021 4:52 pm

I did and that helped although now, the exe screen has errors about not finding a directory?

logs sent: 94020

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: WebBrowser not working

Post by martin@rootjazz » Sat Mar 20, 2021 8:03 pm

Cheerboatfun wrote:
Fri Mar 19, 2021 4:52 pm
I did and that helped although now, the exe screen has errors about not finding a directory?

logs sent: 94020
Close app, check TASK MANAGER and make sure all instances of chrome are closed (ideally restart machine)

Then run it. Usually this issue is cause because chromedriver / chrome left an errant process running which causes issues for subsequent browser sessions.

Cheerboatfun
Posts: 122
Joined: Wed Nov 22, 2017 2:38 pm

Re: WebBrowser not working

Post by Cheerboatfun » Mon Mar 22, 2021 11:17 pm

That worked! thanks

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: WebBrowser not working

Post by martin@rootjazz » Tue Mar 23, 2021 3:02 pm

:)

Brandlabng
Posts: 12
Joined: Fri Apr 30, 2021 3:57 pm

WebBrowser Automation

Post by Brandlabng » Wed May 05, 2021 6:27 pm

Can the webbrowser just take form the cookie the accounts has before instead of login in again??

User avatar
martin@rootjazz
Site Admin
Posts: 27408
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: WebBrowser Automation

Post by martin@rootjazz » Wed May 05, 2021 7:22 pm

Brandlabng wrote:
Wed May 05, 2021 6:27 pm
Can the webbrowser just take form the cookie the accounts has before instead of login in again??
cannot take mobile API cookies, but once logged in it will cookie the browser session

Post Reply