Play Action Failing

Ask any support / help / issues / problem or question related to Soundcloud Manager
Quality1
Posts: 155
Joined: Mon Dec 01, 2014 7:44 am

Play Action Failing

Post by Quality1 » Sat Dec 08, 2018 2:50 pm

Strange error I'm getting when trying to create a Plays actions.

Code: Select all

Scraping track details :https://soundcloud.com/artist-name/song-name
* Problem extracting details for track: https://soundcloud.com/artist-name/song-name Status: -1
* UNKNOWN ERROR OCCURRED - see logs for more info.
If the problem continues, please submit logs to support.
Object reference not set to an instance of an object.
I have submitted logs59818 for this error.

What is strange is that I run multiple instances of SCM, and it's only happening on one specific instance. All instances are the same update version.

Quality1
Posts: 155
Joined: Mon Dec 01, 2014 7:44 am

Re: Play Action Failing

Post by Quality1 » Mon Dec 10, 2018 11:07 pm

Hi Martin -- can you suggest a course of action for me? Play actions still won't work on this one instance of SCM.

Am I forced to uninstall and re-install?

User avatar
martin@rootjazz
Site Admin
Posts: 18433
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Play Action Failing

Post by martin@rootjazz » Tue Dec 11, 2018 12:28 pm

-1 indicates no response from server, no network.

Is it a new machine? If so, check the FIREWALL allows the program in and out.

What OS are you using?

It seems like something on your machine is blocking the running of the program

Please check your anti virus / security software and make sure the applications program files folder:

c:\program files (x86)\APP_NAME

is whitelisted and / or all the .exe and .dlls in that folder.




Regards,
Martin

Quality1
Posts: 155
Joined: Mon Dec 01, 2014 7:44 am

Re: Play Action Failing

Post by Quality1 » Tue Dec 11, 2018 1:27 pm

I've had this VPS for nearly 2.5 years now. No changes have been made.

It should be noted that the VPS IP address is blocked from accessing Soundcloud.com (likely from excess scraping from over the years)

Does the "Help > Config > Default proxy" feature still work as it should? ie. when scraping song details for the Plays module?

Quality1
Posts: 155
Joined: Mon Dec 01, 2014 7:44 am

Re: Play Action Failing

Post by Quality1 » Wed Dec 12, 2018 5:27 am

I have uninstalled / re-installed SCM, doesn't fix the issue.

I believe SCM is trying to scrape Soundcloud without using the Default Proxy function.
Please look into this ASAP, it has rendered one of my licenses/servers useless!

User avatar
martin@rootjazz
Site Admin
Posts: 18433
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Play Action Failing

Post by martin@rootjazz » Wed Dec 12, 2018 9:32 pm

Quality1 wrote:
Tue Dec 11, 2018 1:27 pm
I've had this VPS for nearly 2.5 years now. No changes have been made.

It should be noted that the VPS IP address is blocked from accessing Soundcloud.com (likely from excess scraping from over the years)
Just a little bit of potentially important information :lol: :lol:

This could be the cause
Does the "Help > Config > Default proxy" feature still work as it should? ie. when scraping song details for the Plays module?
yes, this should force all non-proxied calls through the default proxy (example when you add a track to the plays tab and it checks if valid)

User avatar
martin@rootjazz
Site Admin
Posts: 18433
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Play Action Failing

Post by martin@rootjazz » Wed Dec 12, 2018 9:55 pm

confirmed, before the plays start a local IP call is made to check the current #plays and again afterwards, I guess this is crashing you out. Will sort for nextupdate



Regards,
Martin

User avatar
martin@rootjazz
Site Admin
Posts: 18433
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Play Action Failing

Post by martin@rootjazz » Wed Dec 12, 2018 9:58 pm

The next update will fix this. I shall let you know when it is ready.



Regards,
Martin


Quality1
Posts: 155
Joined: Mon Dec 01, 2014 7:44 am

Re: Play Action Failing

Post by Quality1 » Fri Dec 14, 2018 2:15 pm

I tried downloading the new update, but it doesn't work - it just takes me to the homepage.

Post Reply