I can't follow

Support / help / discussion forum for twitter bot
paylituzu
Posts: 5
Joined: Mon Nov 26, 2018 1:16 pm

I can't follow

Post by paylituzu » Fri Jul 19, 2019 11:30 pm

Hey i can't follow

* FAILED: Term: https:/ /twitter.com/user 93748583947069875349764958 : Couldn't get csrf from cookies

Fahad
Posts: 157
Joined: Sat May 18, 2019 2:26 pm

Re: I can't follow

Post by Fahad » Sat Jul 20, 2019 5:59 am

Me Also,

On the last update..

I get it a lot!

I did try to delete cookies again and again.. it worked fro some accounts but some will not and you need to do it manually time after time.

There is something wrong but I don't know what.

Log id: logs_36341

But it had only one account that had the problem.

If you need other account's with the same problem please just let us know :)

Fahad
Posts: 157
Joined: Sat May 18, 2019 2:26 pm

Re: I can't follow

Post by Fahad » Sat Jul 20, 2019 7:22 am

Hmm,

It's critical error.. nothing work anymore.. I did clear cookies a lot of times.. but anyway.. a lot of accounts won't work.. it's almost like there is something wrong with saving cookies!

The first time after cookies cleared it work.. but even if you run a process and it sing in with the account.. it won't continue and it would fail to retrieve the cookies..

So I think the problem is with saving cookies or read there files..

Can't work anymore.. waiting the hero to come and solve it :D

paylituzu
Posts: 5
Joined: Mon Nov 26, 2018 1:16 pm

Re: I can't follow

Post by paylituzu » Sat Jul 20, 2019 9:51 pm

yes thank bro i have 10 accounts not work

Fahad
Posts: 157
Joined: Sat May 18, 2019 2:26 pm

Re: I can't follow

Post by Fahad » Mon Jul 22, 2019 5:03 pm

Please Martin can you solve this..

It's high priority for us.. nothing would work now.

And even if it worked it work for one or two account but the others will fail.. even if you delete the cookies 3 or 4 or 5 times.

User avatar
martin@rootjazz
Site Admin
Posts: 22679
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: I can't follow

Post by martin@rootjazz » Mon Jul 22, 2019 8:54 pm

Working fine here. Need more info. Does it effect all searches or just a particular search for an account? OR is it, once it affects an account that account can not do anything but other accounts are NOT effected?

IF account based, if anyone can export an account, and send it to me for testing:

Code: Select all

support[at]rootjazz[dot]com
Are you forcing these accounts to the old layout?
What layout do they use by default?

Fahad
Posts: 157
Joined: Sat May 18, 2019 2:26 pm

Re: I can't follow

Post by Fahad » Tue Jul 23, 2019 12:16 pm

martin@rootjazz wrote:
Mon Jul 22, 2019 8:54 pm
Working fine here. Need more info. Does it effect all searches or just a particular search for an account? OR is it, once it affects an account that account can not do anything but other accounts are NOT effected?

IF account based, if anyone can export an account, and send it to me for testing:

Code: Select all

support[at]rootjazz[dot]com
Are you forcing these accounts to the old layout?
What layout do they use by default?
Strange.. I didn't have the time to go through every possibility and help with what the problem trigger exactly.

But here is a log of 3 days working for follow operation for 10 account's - some worked and some no.

I did make a count for the
Couldn't get csrf from cookies
and I did find it occur a lot of times.

In this 3 days I didn't clear cookie and to be honest I did start this and forget about it.

So here is the log.

Log_id: logs_89407

I will get back here if I can get a time to test and give you any information that would help.

My thought's is: there is some error with the permission of the file that save cookie or the folder..

In your system I think it should work great.. but here is something make it tricky and work for some and not the other.

BTY: I did export all accounts and restore it (to remove global log).

But I have another TD version on other VPS and I add some new accounts and try to update the account's and get the same error.. I did clear cookie and try again.. and repeat it over and over.. some account's work from the first time.. some after 3 times.. and some take more.

But in the end all worked and update the account information (WOEID) but after that I did a tweet process and return to the "Couldn't get csrf from cookies"

So for that I think the problem is with either reading or writing the cookie information.

Thanks anyway.. Hope I give you a clue about this weird problem.


PS: I think it's best to have a virtual machine or VPS to run test at it other than your main PC.. Why? because there are many things you will see it as us.. from that you will notice obvious things and little things as say chrome driver (We have chrome version 75 which is the stable one.. but I think you got 76 and every time we update TD we need to replace chrome driver)

Just a note from someone who like you and want to help you in any way.. please don't get it as anything else than that.

Big thanks :)

User avatar
martin@rootjazz
Site Admin
Posts: 22679
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: I can't follow

Post by martin@rootjazz » Tue Jul 23, 2019 1:38 pm

Fahad wrote:
Tue Jul 23, 2019 12:16 pm


PS: I think it's best to have a virtual machine or VPS to run test at it other than your main PC.. Why? because there are many things you will see it as us..
:) yes I have access to various VPS servers for testing, don't worry
from that you will notice obvious things and little things as say chrome driver (We have chrome version 75 which is the stable one.. but I think you got 76 and every time we update TD we need to replace chrome driver)
This is a chrome issue. Chrome auto updates chrome (unless specified not to) default is auto update I believe) so most people are always on the latest version of chrome. The program should (when I noticed) always provide the latest chromedriver. IF someone is not on the latest version of chrome, it will be on them to set the correct chromedriver (or keep chrome updated)


The issue is nothing to do with file access, the error is reporting a header expected in the cookies received is not there. Twitter removed it, didn't set it. Why? That is what we are trying to find out. For that, I need a test account where this is happening as it is not effecting any of my accounts on any machine

Fahad
Posts: 157
Joined: Sat May 18, 2019 2:26 pm

Re: I can't follow

Post by Fahad » Tue Jul 23, 2019 2:19 pm

oops.
martin@rootjazz wrote:
Tue Jul 23, 2019 1:38 pm
Fahad wrote:
Tue Jul 23, 2019 12:16 pm


PS: I think it's best to have a virtual machine or VPS to run test at it other than your main PC.. Why? because there are many things you will see it as us..
:) yes I have access to various VPS servers for testing, don't worry
from that you will notice obvious things and little things as say chrome driver (We have chrome version 75 which is the stable one.. but I think you got 76 and every time we update TD we need to replace chrome driver)
This is a chrome issue. Chrome auto updates chrome (unless specified not to) default is auto update I believe) so most people are always on the latest version of chrome. The program should (when I noticed) always provide the latest chromedriver. IF someone is not on the latest version of chrome, it will be on them to set the correct chromedriver (or keep chrome updated)


The issue is nothing to do with file access, the error is reporting a header expected in the cookies received is not there. Twitter removed it, didn't set it. Why? That is what we are trying to find out. For that, I need a test account where this is happening as it is not effecting any of my accounts on any machine
aah, now it's clear.. so clever :).

I will send the accounts details tonight with the other accounts affected with recapcha.. as soon as I can.

Thanks in advance :)

Robertos
Posts: 57
Joined: Wed Nov 15, 2017 3:44 pm

Re: I can't follow

Post by Robertos » Tue Jul 23, 2019 10:02 pm

The issue is nothing to do with file access, the error is reporting a header expected in the cookies received is not there. Twitter removed it, didn't set it. Why? That is what we are trying to find out. For that, I need a test account where this is happening as it is not effecting any of my accounts on any machine
For me its happening mostly for new accounts/layout

what is works for me

1. New account made, phone verified, imported in TD. I hit "verify login web" button and receive a message in processor tab like this
https://prnt.sc/oj4agk

you can think it's ok but it isn't. Cant do any task with it

2. Go to Acc TAB hit "open acc in session browser" and got something like this
https://prnt.sc/oj4c1f

it is loged in ( i think) but the account is not functional at all

I close that Chromium browser and delete coockies+reset user agent for that acc. Hit again "open acc in session browser" fill username + pass hit log in and twitter now redirect me at solving captcha/PV page after I do that close Chromium browser.

3. Again hit "verify login web" button and again receive a message in processor tab like this
https://prnt.sc/oj4agk

but again I don't know is it functional or not

4. So I need to keep reset cookies/user agent till I see a message like this
https://prnt.sc/oj464m

then I know I can do tasks with that account in TD.
It will work till again I'm hit by captcha/PV or something like that.

Different user agents don't work the same way.

So (I think) it is related to the user agent/cookies used and updated twitter UI, please fix it it is too much hassle for me :), and again sorry for my bad engl

EDIT: I recall everything I was said... maybe its just cookies I really don't know sometimes work sometimes don't

Post Reply