Issue With Failing Actions

Ask any support / help / issues / problem or question related to Soundcloud Manager
User avatar
martin@rootjazz
Site Admin
Posts: 21256
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Issue With Failing Actions

Post by martin@rootjazz » Tue Jun 04, 2019 6:35 pm

so, for the CUSTOM SEARCH, you didn't set the step limits, so it will scrape all.
You requested 2000 results.

That means, the program needs to scrape the results, then loop over the results, 1 by 1, pulling the details for each results, check it for the filter.

This will take time.

Without the filter, you scrape the 2000 results in about 90seconds
12:55:34: Current Results: 0
12:55:34: Results : 60 https://soundcloud.com/officialnocap/no-jewelry-1
...
12:55:59: Results : 2719 https://soundcloud.com/officialnocap/no-jewelry-1
12:55:59: invalid nexturl - drop outnull?client_id=ifoUhYX2sDPbwwgaMnEYpMUXFBBWMQ3l&app_version=1559643780

Then assuming a time of 15 seconds for each request to check each results, that is 2000 x 15secs = 30,000secs = 8.3hours

So it is going to take some time. If you want it quicker, remove the filter, reduce the number of results you want.


Just running tests now to make sure, the issue isn't that the action is running, but not logging out

User avatar
martin@rootjazz
Site Admin
Posts: 21256
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Issue With Failing Actions

Post by martin@rootjazz » Tue Jun 04, 2019 6:40 pm

It seems like your track input has purchased likes. SCM scraped 2000+ likers, and is checking their latest track, the vast majority of likers have no tracks, investigating them - they look fake.

So not only does the action have to
a) scrape 2000+ likes
b) scrape the latest track of each
c) check the filter for each track

but lots of "get latest post" of profile is getting 0 results, so having to make lots of requests that is not finding results.

User avatar
martin@rootjazz
Site Admin
Posts: 21256
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Issue With Failing Actions

Post by martin@rootjazz » Tue Jun 04, 2019 6:41 pm

But the actions are running and logging.

Your previous logs: logs_61216_...
Again do not show your action running / pausing / freezing. The logs show it working when you submitted logs.

Can you run the action, then wait UNTIL YOU NOTICE THE ISSUE, then submit logs, otherwise all I can see and say is "it is working" as that is what the logs show

User avatar
martin@rootjazz
Site Admin
Posts: 21256
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Issue With Failing Actions

Post by martin@rootjazz » Tue Jun 04, 2019 6:43 pm

So what I advise is, think about your search, research it. Look at what results you expect.

check the track
check the likers
check their most recent tracks
Most profiles look fake / have no tracks.

Thus is not a good search to run.

Also, run tests, request 10 results with no filter, can you find anything? If so, try with a filter, does it run and find results promptly?

Then once you are assured it is a good search and has potential results, then run the action action of 2000 likes

wowthatscool
Posts: 60
Joined: Sun Mar 24, 2019 4:40 am

Re: Issue With Failing Actions

Post by wowthatscool » Tue Jun 04, 2019 7:04 pm

martin@rootjazz wrote:
Tue Jun 04, 2019 6:43 pm
So what I advise is, think about your search, research it. Look at what results you expect.

check the track
check the likers
check their most recent tracks
Most profiles look fake / have no tracks.

Thus is not a good search to run.

Also, run tests, request 10 results with no filter, can you find anything? If so, try with a filter, does it run and find results promptly?

Then once you are assured it is a good search and has potential results, then run the action action of 2000 likes
Ok thank you very much. This was informitive. I will try this without the filter

User avatar
martin@rootjazz
Site Admin
Posts: 21256
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Issue With Failing Actions

Post by martin@rootjazz » Tue Jun 04, 2019 9:01 pm

Please keep me informed. I am still not 100% sure I understand your issue tbh. From your logs, I do not see any *issue* (as in something going wrong - but that could be you submitted logs before it occurs, or me just not understanding).

But do be aware of accounts and fake followers / likes etc. I have seen people follow thousands and thousands of fake accounts from poorly chosen searches. Blindly following followers_of major accounts, where on inspection, there were nearly all fake. Same with likes, it is very easy to buy fake likes and certain styles / genres / accounts are worse than others for this.

Think about who you are targeting, who is likely to respond to your interactions (followers / likes / comments).

various types of users use SC, artists / fans. Fans who just follow major accounts and don't care at all for finding unknown artists. Major artists are not going to notice you liking their track as probably the SC profile is managed by an AR company.

Again, big searches / complex custom searches / filters all increase processing time. Run samples, check results, then when you think you have a good search + settings, then set it running on autopilot. It is more work, but in the long run the results are better



Regards,
Martin

wowthatscool
Posts: 60
Joined: Sun Mar 24, 2019 4:40 am

Re: Issue With Failing Actions

Post by wowthatscool » Fri Jun 14, 2019 3:50 pm

martin@rootjazz wrote:
Tue Jun 04, 2019 9:01 pm
Please keep me informed. I am still not 100% sure I understand your issue tbh. From your logs, I do not see any *issue* (as in something going wrong - but that could be you submitted logs before it occurs, or me just not understanding).

But do be aware of accounts and fake followers / likes etc. I have seen people follow thousands and thousands of fake accounts from poorly chosen searches. Blindly following followers_of major accounts, where on inspection, there were nearly all fake. Same with likes, it is very easy to buy fake likes and certain styles / genres / accounts are worse than others for this.

Think about who you are targeting, who is likely to respond to your interactions (followers / likes / comments).

various types of users use SC, artists / fans. Fans who just follow major accounts and don't care at all for finding unknown artists. Major artists are not going to notice you liking their track as probably the SC profile is managed by an AR company.

Again, big searches / complex custom searches / filters all increase processing time. Run samples, check results, then when you think you have a good search + settings, then set it running on autopilot. It is more work, but in the long run the results are better



Regards,
Martin
I dont know what the problem is. things were working for a little bit but now its back to taking more time than it should. I have no filter on it. I have some low 100 favorite actions and it has been taking over a day. It was working for a couple days. I slowly eased into adding more actions and it was working but now all the sudden its not working. I dont know what its doing but its stuck on the same line. But if i delete all the actions and do 1 to send to you then if it still doesnt work then i just delted all the actions that has been loading for days

User avatar
martin@rootjazz
Site Admin
Posts: 21256
Joined: Fri Jan 25, 2013 10:06 pm
Location: The Funk
Contact:

Re: Issue With Failing Actions

Post by martin@rootjazz » Fri Jun 14, 2019 6:32 pm

wowthatscool wrote:
Fri Jun 14, 2019 3:50 pm
martin@rootjazz wrote:
Tue Jun 04, 2019 9:01 pm
Please keep me informed. I am still not 100% sure I understand your issue tbh. From your logs, I do not see any *issue* (as in something going wrong - but that could be you submitted logs before it occurs, or me just not understanding).

But do be aware of accounts and fake followers / likes etc. I have seen people follow thousands and thousands of fake accounts from poorly chosen searches. Blindly following followers_of major accounts, where on inspection, there were nearly all fake. Same with likes, it is very easy to buy fake likes and certain styles / genres / accounts are worse than others for this.

Think about who you are targeting, who is likely to respond to your interactions (followers / likes / comments).

various types of users use SC, artists / fans. Fans who just follow major accounts and don't care at all for finding unknown artists. Major artists are not going to notice you liking their track as probably the SC profile is managed by an AR company.

Again, big searches / complex custom searches / filters all increase processing time. Run samples, check results, then when you think you have a good search + settings, then set it running on autopilot. It is more work, but in the long run the results are better



Regards,
Martin
I dont know what the problem is. things were working for a little bit but now its back to taking more time than it should. I have no filter on it. I have some low 100 favorite actions and it has been taking over a day.
What do you mean by low? Can you give a rough over view of the action? max_items / search?

I dont know what its doing but its stuck on the same line.
How many actions are processing in the processor?
What line is it?
IF you view the RAW LOG of the file (right click action >raw log) or HELP > LOGS > VIEW and try to find the correct file. Is the raw log stuck on the same line or does it appear to be writing an updating normally?
But if i delete all the actions and do 1 to send to you then if it still doesnt work
so a single action test also didn't work? did you send logs?
then i just delted all the actions that has been loading for days
What do you mean "loading for days"?

wowthatscool
Posts: 60
Joined: Sun Mar 24, 2019 4:40 am

Re: Issue With Failing Actions

Post by wowthatscool » Fri Jun 14, 2019 9:59 pm

martin@rootjazz wrote:
Fri Jun 14, 2019 6:32 pm
wowthatscool wrote:
Fri Jun 14, 2019 3:50 pm
martin@rootjazz wrote:
Tue Jun 04, 2019 9:01 pm
Please keep me informed. I am still not 100% sure I understand your issue tbh. From your logs, I do not see any *issue* (as in something going wrong - but that could be you submitted logs before it occurs, or me just not understanding).

But do be aware of accounts and fake followers / likes etc. I have seen people follow thousands and thousands of fake accounts from poorly chosen searches. Blindly following followers_of major accounts, where on inspection, there were nearly all fake. Same with likes, it is very easy to buy fake likes and certain styles / genres / accounts are worse than others for this.

Think about who you are targeting, who is likely to respond to your interactions (followers / likes / comments).

various types of users use SC, artists / fans. Fans who just follow major accounts and don't care at all for finding unknown artists. Major artists are not going to notice you liking their track as probably the SC profile is managed by an AR company.

Again, big searches / complex custom searches / filters all increase processing time. Run samples, check results, then when you think you have a good search + settings, then set it running on autopilot. It is more work, but in the long run the results are better



Regards,
Martin
I dont know what the problem is. things were working for a little bit but now its back to taking more time than it should. I have no filter on it. I have some low 100 favorite actions and it has been taking over a day.
What do you mean by low? Can you give a rough over view of the action? max_items / search?

I dont know what its doing but its stuck on the same line.
How many actions are processing in the processor?
What line is it?
IF you view the RAW LOG of the file (right click action >raw log) or HELP > LOGS > VIEW and try to find the correct file. Is the raw log stuck on the same line or does it appear to be writing an updating normally?
But if i delete all the actions and do 1 to send to you then if it still doesnt work
so a single action test also didn't work? did you send logs?
then i just delted all the actions that has been loading for days
What do you mean "loading for days"?
im doing the same action i was doing. All track interaction , latest track of, with no filter. But all of the sudden the actions are just getting stuck at "Start search: Latest track of with: https://soundcloud.com/user-276252737(10) using: Ad Lib God" All of my max fav settings are pretty low (all below 2,000) But ive had the actions going for 3 days and had no results. Here is my log number 52964. I know there is a ton of logs on there probably but i dont really want to cancel all my actions because i already have had them going for 3 days. Maybe they will eventally unfreeze? Im gonna start messing around with settings and trying to figure out the problem

wowthatscool
Posts: 60
Joined: Sun Mar 24, 2019 4:40 am

Re: Issue With Failing Actions

Post by wowthatscool » Fri Jun 14, 2019 10:10 pm

wowthatscool wrote:
Fri Jun 14, 2019 9:59 pm
martin@rootjazz wrote:
Fri Jun 14, 2019 6:32 pm
wowthatscool wrote:
Fri Jun 14, 2019 3:50 pm


I dont know what the problem is. things were working for a little bit but now its back to taking more time than it should. I have no filter on it. I have some low 100 favorite actions and it has been taking over a day.
What do you mean by low? Can you give a rough over view of the action? max_items / search?

I dont know what its doing but its stuck on the same line.
How many actions are processing in the processor?
What line is it?
IF you view the RAW LOG of the file (right click action >raw log) or HELP > LOGS > VIEW and try to find the correct file. Is the raw log stuck on the same line or does it appear to be writing an updating normally?
But if i delete all the actions and do 1 to send to you then if it still doesnt work
so a single action test also didn't work? did you send logs?
then i just delted all the actions that has been loading for days
What do you mean "loading for days"?
im doing the same action i was doing. All track interaction , latest track of, with no filter. But all of the sudden the actions are just getting stuck at "Start search: Latest track of with: https://soundcloud.com/user-276252737(10) using: Ad Lib God" All of my max fav settings are pretty low (all below 2,000) But ive had the actions going for 3 days and had no results. Here is my log number 52964. I know there is a ton of logs on there probably but i dont really want to cancel all my actions because i already have had them going for 3 days. Maybe they will eventally unfreeze? Im gonna start messing around with settings and trying to figure out the problem
the max fav setting doesnt seem to do anything. I shorted it to 1 and it still is stuck. I lowered it and its still stuck. I thought that setting would shorten the time

Post Reply